RaspberryPi に nodejs の bluetooth-serial-port を npm install する。

Raspberry Pi にて

 

npm install bluetooth-serial-port

 

しようとすると、エラーが出てインストールできませんでした。
よくよく確認すると、

 

error: #error This version of node/NAN/v8 requires a C++11 compiler

 

と表示されていて、g++ コンパイラのバージョンが低くてこけているようです。
(さらに…)

続きを読む

Raspberry Pi node.js セットアップ

ラズパイにて

  1. nodebrew インストール
    curl -L git.io/nodebrew | perl - setup
  2. 以下のパスを追加する。
    vi ~/.bashrc
    -- ここから --
    export PATH=$HOME/.nodebrew/current/bin:$PATH
    -- ここまで --
  3. 設定の読み込み
    source ~/.bashrc
  4. インストールできるバージョンのリストを確認
    nodebrew ls-remote
  5. 最新版の v5.1.0 をインストール(install だと5〜6時間かかるかもしれないので覚悟すること)
    nodebrew install v5.1.0

    もしくは

    nodebrew install-binary v5.1.0
  6. 使用バージョンの設定
    nodebrew use v5.1.0
  7. インストール確認
    node -v

(さらに…)

続きを読む